[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [iaik-jce] problem verifying certificate



> I'm working on AIX operating system. I don't find any problems while using
> jdk1.3 as the jvm but encounter this exception when using ibm jdk1.1.8.

I think this makes it fairly obvious that this is a JDK bug. You should try
disabling the JIT in 1.1.8 (if available) or use 1.3 instead.

 Andreas Sterbenz              mailto:Andreas.Sterbenz@iaik.at


----- Original Message -----
From: "Bharath Vutukuru" <bvuturur@osf1.gmu.edu>
To: <iaik-jce@iaik.at>
Sent: Tuesday, December 05, 2000 1:44 AM
Subject: [iaik-jce] problem verifying certificate


> Hi
> I see this exception message when trying to verify the certificate. Can
> anyone tell me what could be the problem??
> I'm working on AIX operating system. I don't find any problems while using
> jdk1.3 as the jvm but encounter this exception when using ibm jdk1.1.8.
>
> java.lang.ArrayIndexOutOfBoundsException: -17
>         at iaik.security.md.Md2.a(Compiled Code)
>         at iaik.security.md.Md2.engineUpdate(Compiled Code)
>         at java.security.MessageDigest.update(Compiled Code)
>         at iaik.security.rsa.RSASignature.engineUpdate(Compiled Code)
>         at java.security.Signature.update(Compiled Code)
>         at java.security.Signature.update(Compiled Code)
>         at iaik.x509.X509Certificate.verify(Compiled Code)
>         at iaik.x509.X509Certificate.verify(Compiled Code)


--
Mailinglist-archive at
http://jcewww.iaik.at/mailarchive/iaik-jce/jcethreads.html

To unsubscribe send an email to listserv@iaik.at with the folowing content:
UNSUBSCRIBE iaik-jce